Преддипломную практику проходил в ООО «Фирма «КЛОН». Организация основана в 1991 году и является беспроводным оператором связи, построившим в городе Снежинске развитую высокоскоростную опорную сеть цифровой передачи данных. Компания обладает всеми необходимыми лицензиями на предоставление услуг связи.

Содержание

Введение
Глава 1. Анализ предприятия
1.1. Описание структуры предприятия
1.2. Описание финансово-экономической части
1.3. Описание основных бизнес процессов
Глава 2. Анализ информационных системы предприятия
2.1. Описание технических средств информационных систем предприятия
2.2. Описание системного программного обеспечения
2.3. Описание прикладного программного обеспечения
2.4. Описание локальной сети
Глава 3. Индивидуальное задание
Заключение
Список использованных источников

Введение

Преддипломную практику проходил в ООО «Фирма «КЛОН». Организация основана в 1991 году и является беспроводным оператором связи, построившим в городе Снежинске развитую высокоскоростную опорную сеть цифровой передачи данных. Компания обладает всеми необходимыми лицензиями на предоставление услуг связи.

С 2002 года Фирма Клон приступила к реализации программы по предоставлению доступа в Интернет для частных лиц.

Доступ обеспечивается по технологиям Wi-Fi и Ethernet через беспроводную опорную сеть «CLONNET» на всей территории города Снежинска и в пригородах.

Руководитель практики от предприятия директор ООО «Фирма «КЛОН» Платонов Сергей Александрович. Он не только отличный управленец, но и опытный инженер-связист.

Глава 1. Анализ предприятия

1.1. Описание структуры предприятия

В ООО «Фирма «КЛОН» линейная организационная структура управления, которая характеризуется тем, что во главе каждого структурного подразделения находится руководитель-единоначальник, наделенный всеми полномочиями и осуществляющий единоличное руководство подчиненными ему работниками и сосредоточивающий в своих руках все функции управления.

При линейном управлении каждое звено и каждый подчиненный имеют одного руководителя, через которого по одному единовременному каналу проходят все команды управления. В этом случае управленческие звенья несут ответственность за результаты всей деятельности управляемых объектов. Речь идет о по объектном выделении руководителей, каждый из которых выполняет все виды работ, разрабатывает и принимает решения, связанные с управлением данным объектом.

Нужна помощь в написании отчета?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Поможем с характеристой и презентацией. Правки внесем бесплатно.

Подробнее

1.2. Описание финансово-экономической части

Анализ финансово-экономического состояния организации предполагает следующие этапы:

  1. Экспресс-оценка финансового положения организации;
  2. Оценка имущественного положения;
  3. Оценка ликвидности, финансовой устойчивости;
  4. Оценка рентабельности;
  5. Оценка деловой активности.

Экспресс-оценка финансового положения предприятия заключается в расчете ликвидности и финансовой устойчивости организации.

Коэффициент текущей ликвидности характеризует общую обеспеченность организации собственными оборотными средствами для ведения хозяйственной деятельности и своевременного погашения срочных обязательств. Финансовая устойчивость определяется с помощью коэффициента обеспеченности собственными оборотными средствами, который характеризует наличие у организации собственных оборотных средств, необходимых для ее финансовой отчетности.

Нормативными значение коэффициента текущей ликвидности для данной организации составляет 1,0, а коэффициента обеспеченности собственными оборотными средствами составляет 0,13.

В целом можно сделать вывод, что ООО «Фирма «Клон» платежеспособна.

Следующим этапом экономического анализа является оценка имущественного положения предприятия.

Устойчивость финансового положения организации в значительной степени зависит от целесообразности и правильности вложения финансовых ресурсов в активы, величина и структура которых, в процессе функционирования организации претерпевают постоянные изменения. Наиболее общее представление об имевших место качественных изменениях в структуре средств и источников, а также динамике этих изменений можно получить с помощью вертикального и горизонтального анализов данных бухгалтерской отчетности.

Основой вертикального анализа активов и пассивов предприятия является представление бухгалтерской отчетности в виде относительных величин, характеризующих структуру обобщающих итоговых:

Как положительную тенденцию следует отметить увеличение высоколиквидных активов – денежных средств и финансовых вложений.

Наибольший удельный вес в активе «Фирмы «Клон» имеют оборотные активы. В составе оборотных активов наибольшую долю составляют запасы и затраты и прочие оборотные активы. Основную величину запасов и затрат составляют сырье и материалы. Это связано с особенностями организации производства и сбыта. Оборотные активы являются наиболее ликвидной частью имущества предприятия. Большая доля запасов и затрат может приводить к увеличению издержек на их хранение и обслуживание. Но при этом в балансе возрастает величина дебиторской задолженности. Однако предприятие все равно должно стремиться к снижению доли дебиторской задолженности, т.к. это может привести к затруднению предприятия с расчетами по краткосрочным обязательствам.

Во внеоборотных активах наибольшую долю составляют основные средства. В целом доля основных средств колеблется в пределах 92% — 97%, но остается на достаточно высоком уровне. Основную величину кредиторской задолженности составляют расчеты с поставщиками и подрядчиками. Как положительную тенденцию следует отметить снижение доли долгосрочных кредитов и займов.

В целом предприятие имеет удовлетворительную вертикальную структуру баланса.

Вертикальный анализ активов и пассивов предприятия дополняется горизонтальным анализом.

Горизонтальный анализ отчетности заключается в построении одной или нескольких аналитических таблиц, в которых относительные показатели дополняются относительными, характеризующими темпы роста (снижения). Как правило, берутся базисные темпы роста за ряд лет, благодаря чему можно анализировать не только изменение отдельных показателей, но и прогнозировать их значения. Горизонтальный анализ отчетности позволяет выявить тенденции изменения отдельных статей или их групп, входящих в состав бухгалтерской отчетности.

Величина внеоборотных активов на протяжении пяти лет все время увеличивалась. Основную величину этого изменения составило увеличение основных средств.

В целом по проведенному горизонтальному и вертикальному анализу можно сделать вывод, что изменения, произошедшие в балансе, носят в основном положительный характер.

Нужна помощь в написании отчета?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Поможем с характеристой и презентацией. Правки внесем бесплатно.

Подробнее

Затем на предприятии проводится оценка финансовой устойчивости.

Для анализа финансовой устойчивости применяется целый ряд коэффициентов, которые в определенной степени показывают уровень финансовой устойчивости. Объективную оценку степени финансовой устойчивости организации дают эти показатели в комплексе:

Коэффициент автономии отражает степень зависимости организации от заемных средств. Чем выше значение этого коэффициента, тем более финансово устойчива, стабильна и независима от внешних кредиторов организация. В целом значение данного коэффициента слишком низко.

Коэффициент финансовой устойчивости дает наиболее общую оценку финансовой устойчивости организации. Он должен стремиться к 1. Если он ниже единицу, то это свидетельствует о потере финансовой устойчивости и достижении ее критической точки. К сожалению, значение данного коэффициента стремительно падает, что говорит о неустойчивом положении предприятия. Снижение этого коэффициента произошло за счет роста расчетов, причем наибольшую долю в этом росте составила кредиторская задолженность.

Коэффициент соотношения собственных и привлеченных средств показывает, в каком объеме предприятие привлекает средства для текущей финансовой деятельности.

Коэффициент банкротства показывает возможность рассчитаться с обязательствами после реализации активов или долю привлеченных средств в общей сумме имущества.

Коэффициент не должен превышать 0,5. В нашем случае состояние фирмы оценивается как стабильное.

В целом по предприятию можно отметить, что оборачиваемость активов находится на достаточно хорошем уровне, это свидетельствует о высокой интенсивности использования капитала ООО «Фирмой «Клон».

1.3. Описание основных бизнес процессов

Бизнес-процесс — это множество внутренних шагов (видов) деятельности, начинающихся с одного или более входов и заканчивающихся созданием продукции, необходимой клиенту. Назначение каждого бизнес-процесса состоит в том, чтобы предложить клиенту товар или услугу, удовлетворяющую его по стоимости, долговечности, сервису и качеству.

Различают внешнюю и внутреннюю модель бизнес-процессов для компании связи.

Внешняя модель описывает взаимоотношения данной компании связи с клиентом и другими компаниями связи. Здесь чрезвычайно важна детальная проработка интерфейса между клиентом и процессом компании.

Внутренняя модель соответственно предназначена для описания того, из каких внутренних процессов (рабочих задач) состоит бизнес-процесс компании.

На предприятии OOO «Фирма клон» можно выделить следующие бизнес процессы:

  • биллинговая система, которая охватывает вопросы, связанные с заключением и расторжением договоров, оплатой услуг и возвратом денежных средств клиентам в случае расторжения договора и тд;
  • техническая поддержка – структура, разрешающая проблемы пользователей;
  • администрирование – структура, занимающаяся настройкой оборудования, резервным копированием данных, защитой данных и тд;
  • бухгалтерия

Глава 2. Анализ информационных системы предприятия

2.1. Описание технических средств информационных систем предприятия

В фирме используют технические средства различных вендоров: ASUS, Gigabyte. Процессоры фирм Intel, AMD. Графические карты Nvidia, AMD. Сервера IBM, HP. Сетевое оборудование MikroTik, Dlink, Acorp, ZyXEL, Tp-Link и д.р.

2.2. Описание системного программного обеспечения

На предприятии используется операционные системы MikroSoft, некоторые сервера работают на ОС Linux (Debian, CentOS). Некоторое системное ПО является самописным и уникальным.

2.3. Описание прикладного программного обеспечения

В ООО «Фирма «КЛОН» используется прикладное ПО таких производителей, как MikroSoft, Adobe. Так же присутствуют самописное ПО: биллинговая система, системы учета, различное бухгалтерское ПО.

2.4. Описание локальной сети

ООО «Фирма «КЛОН» занимается предоставлением интернета физическим и юридическим лицам в городе и ряде населенных пунктах. В виду этого имеется обширная, развитая сеть. Ядро сети базируется на оборудовании MikroTik и нескольких серверах с ПО от MicroSoft. Имеется выход через Ростелеком и ТрансТелеКом посредством оптоволоконного соединения. Оборудованием доступа базируется на MikroTik и различных других вендорах (Dlink, Acorp, Tplink, ZyXel и т.д.). Связь между узлами сети в основном посредством радиоканала, часто соединены в Mesh сеть. Маршрутизация на основе OSPF, BGP. Некоторые узлы соединяются на расстояниях более 50 км. «Фирма «КЛОН» предоставляет различные сервисы: Хостинг, Файловые хранилища, Электронную почту, IP телефония.

Глава 3. Индивидуальное задание

ООО «Фирма «КЛОН» – оператор связи, оказывающий услуги по предоставлению доступа к информационно-телекоммуникационной сети «Интернет». Согласно федеральному закону № 139-ФЗ[1] от 28 июля 2012 года обязан ограничить доступ к доменным именам, указателям страниц сайтов в сети «Интернет» и сетевым адресам, позволяющих идентифицировать сайты в сети «Интернет», содержащие информацию, распространение которой в Российской Федерации запрещено или распространяемую с нарушением исключительных прав. Перечень доменных имен, указателей страниц сайтов в сети «Интернет» и сетевых адресов, позволяющих идентифицировать сайты в сети «Интернет», находится в едином реестре запрещенных сайтов.

Моим заданием являлось создание программно-аппаратного комплекса, который в автоматическом режиме периодически выгружал дамп реестра запрещенных сайтов и ограничивал доступ к ресурсам. Ввиду того, что в ООО «Фирма «КЛОН» используется сетевое оборудование фирмы MikroTik, то и решение базировалось на данном оборудовании. Программная часть базируется на платформе MikroSoft Windows Server 2012 написанная на языке C# для MikroSoft .NET FrameWork 4.5 в MikroSoft Visual Studio 2012 Professional.

Нужна помощь в написании отчета?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Поможем с характеристой и презентацией. Правки внесем бесплатно.

Цена отчета

Получить дамп реестра возможно двумя путями. Первый ручной, через форму на страничке сайта eais.rkn.gov.ru, второй автоматически, используя протокол SOAP. В обоих случаях необходимо создать файл запроса и подписать его квалифицированной электронной подписью, выданной любым удостоверяющим центром, из числа аккредитованных Минкомсвязи России. Тем самым получается два файла: файл запроса и файл открепленной электронной подписи в формате PKCS#7. Запрос – это XML файл в Windows-1251 кодировке несущий в себе следующую информацию об операторе связи:

  • Дата и время формирования запроса с указанием временной зоны (имя поля requestTime);
  • Полное наименование оператора связи (operatorName);
  • ИНН оператора связи (inn);
  • ОГРН оператора связи (ogrn);
  • Электронный адрес технического специалиста, ответственного за использование механизма получения выгрузки (email).

Пример файла запроса (request.xml):

<?xml version=»1.0″ encoding=»windows-1251″?>

<request>

<requestTime>2013-10-28T10:30:58.000+06:00</requestTime>

<operatorName>ООО фирма ‘КЛОН'</operatorName>

<inn>7423001826</inn>

<ogrn>1027401354639</ogrn>

<email>[email protected]</email>

</request>

Для генерации файла запроса была написана соответствующая функция на языке C#. Для подписи файла запросы решено было использовать OpenSSL. Для этого необходимы было получить ЭЦП  в формате PKCS#12. С этим справилась программа P12FromGostCSP (программа для резервного копирования сертификатов ключей проверки ЭП из криптопровайдера Microsoft CSP с российской криптографией). Ее использование обусловленно тем, что контейнер PKCS#12, создаваемый утилитой P12FromGostCSP полностью совместим с аналогичными контейнерами, создаваемыми ООО «КриптоКом» (в рамках проекта OpenSSL) и ООО «Топ Кросс», чего, к сожалению, не скажешь о контейнере, создаваемом программными средствами, входящими в состав КриптоПро CSP (начиная с версии R3). Дальше файл ЭЦП в формате PKCS#12 необходимы было преобразовать в формат PEM. Это выполняется с помощью OpenSSL:

openssl.exe pkcs12 -in C:/key.pfx -out C:/key.pem -nodes –clcerts

После этого стало возможно подписать файл запроса командой:

openssl.exe smime -sign -in c:/request.xml -out c:/request.xml.sign -signer c:/key.pem -outform DER

Прежде чем приступить к ручной выгрузке реестра, необходимо удостоверится в успешной подписи файла, что можно сделать на сайте госуслуг: http://www.gosuslugi.ru/pgu/eds/ выбрав «Подтверждение подлинности электронного документа. ЭП — отсоединенная, в формате PKCS#7».

После отправки файлов запроса и подписи, если они верно составлены, придет идентификатор запроса. Данный идентификатор запроса необходимо использовать через минут десять во второй форме. В ответ получаем ZIP архив дампа реестра в котором находится файл дампа реестра в XML формате и открепленная электронная подпись в формате PKCS#7.

Пример файла дампа реестра:

<?xml version=»1.0″ encoding=»windows-1251″?>

<reg:register updateTime=»2012-01-02T05:05:05″ xmlns:reg=»http://rsoc.ru»>

<content id=»1″ includeTime=»2012-01-01T01:01:01″>

<decision date=»2012-01-01″ number=»Решение №1″ org=»ФОИВ №1″/>

<url><![CDATA[http://site1.ru/page1.html]]></url>

<ip>1.1.1.1</ip>

</content>

<content id=»2″ includeTime=»2012-02-02T01:01:01″>

<decision date=»2012-01-01″ number=»Решение №2″ org=»ФОИВ №2″/>

<domain><![CDATA[site2.ru]]></domain>

<ip>2.2.2.2</ip>

<ip>3.3.3.3</ip>

</content>

</reg:register>

Для выгрузки реестра в автоматическом режиме используется адрес веб-сервиса http://vigruzki.rkn.gov.ru/services/OperatorRequest/ с которым посредством SOAP протокола необходимо осуществить те же шаги что и при ручном режиме. Для этого есть WSDL схема по адресу: http://vigruzki.rkn.gov.ru/services/OperatorRequest/?wsdl

Нужна помощь в написании отчета?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Поможем с характеристой и презентацией. Правки внесем бесплатно.

Подробнее

Сервис состоит из 3-х методов:

  1. getLastDumpDate – метод предназначен для получения временной метки последнего обновления выгрузки из реестра;
  2. sendRequest – метод предназначен для направления запроса на получение выгрузки из реестра, принимает requestFile и signatureFile в base64Binary формате – файл запроса и его подписи (с:/request.xml и с:/request.xml.sign). В ответ присылает result – результат обработки запроса в boolean формате и если все удачно, то code – идентификатор запроса, строка по которой необходимо получить выгрузку из реестра в формате string, так же resultComment – комментарий к результату обработки запроса в формате string.
  3. getResult – метод предназначен для получения результата обработки запроса – выгрузки из реестра, принимает code – идентификатор запроса, строка по которой необходимо получить выгрузку из реестра в формате string. В ответ присылает result – результат обработки запроса в boolean формате и если все удачно, то registerZipArchive – файл zip-архив с выгрузкой из реестра в формате base64Binary, так же resultComment – комментарий к результату обработки запроса в формате string.

Алгоритм работы: получаем временную метку последнего обновления реестра, если она изменилась, то направляем запрос на получение выгрузки из реестра, если все удачно, то через 10 минут забираем дамп реестра.

После получения реестра его необходимо распаковать и разобрать. Для этого были написаны соответствующие функции и классы.

Дальше необходимо было записать полученную информацию в базу данных.

Следующий шаг это создание правил для оборудования MikroTik. Вначале идея была проста: используя регулярные выражения L7 фильтровать исходящие пакеты содержащие обращение к запрещенным URL адресам. Ввиду того что L7 занимается полным разбором пакетов, то его использование сильно нагружает оборудование. Чтобы избежать этого был создан список IP адресов преобразованных посредством DNS из доменных имен. Выделяя данные пакеты и применив к ним фильтр получили желаемый результат. Пример конфигурации:

Локальная сеть из которой запрещаем доступ к запрещенным URL адресам – 192.168.0.0/24

Запрещенный URL адрес: http://chelaxe.ru/summary/

Узнаем у DNS сервера IP адрес домена chelaxe.ru – 91.201.52.97

Нужна помощь в написании отчета?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Поможем с характеристой и презентацией. Правки внесем бесплатно.

Цена отчета

Команды для MikroTik RouterOS:

/ip firewall layer7-protocol add name=chelaxe regexp=^.*(\/summary\/).*(chelaxe\.ru).*$

/ip firewall filter add action=drop chain=forward disabled=no dst-port=80 layer7-protocol=chelaxe protocol=tcp src-address=192.168.0.0/24 dst-address=91.201.52.97

Данный подход просто уничтожает пакеты запроса по URL адресу. У клиента не отображается страничка и для него это выглядит непонятно. По этой причине следующим шагом было создание сайта заглушки и перенаправление запрещенного трафика к нему.

Очевидным решением было перенаправлять трафик выделенный посредством L7 используя NAT. Пример:

192.168.0.200:80 – сайт заглушка.

/ip firewall mangle add action=jump jump-target=registry chain=prerouting dst-address=91.201.52.97 dst-port=80 protocol=tcp src-address=192.168.0.0/24

/ip firewall layer7-protocol add name=chelaxe regexp=^.*(\/summary\/).*(chelaxe\.ru).*$

/ip firewall mangle add action=mark-packet chain=registry layer7-protocol=chelaxe new-packet-mark=reg passthrough=no

/ip firewall nat add action=dst-nat chain=dstnat dst-port=80 packet-mark=reg protocol=tcp to-addresses=192.168.0.200 to-ports=80

Но данный подход не сработал. Причины была в медленной обработке пакетов посредством L7. По этому от L7 пришлось отказаться. Реализация этой задачи стало использование прокси встроенного в MikroTik. Логика работы осталась та же. Выбирая пакеты по IP адресу назначения который принадлежит запрещенному домену, мы перенаправляем на порт прокси, где в его правилах запрещаем доступ по определенному URL адресу. Пример:

/ip firewall nat add action=redirect chain=dstnat comment=registry dst-address=91.201.52.97 dst-port=80 protocol=tcp src-address=192.168.0.0/24 to-ports=8080 /ip proxy access add action=deny dst-host=chelaxe.ru path=/summary/ redirect-to=192.168.0.200

Теперь клиент видит сайт заглушку и понимает причину отсутствия доступа.

Весь этот функционал был реализован в виде службы Windows. Данную службу можно разделить на следующие функциональные блоки:

  • Сама службы по автоматической выгрузки реестра и применения его на оборудовании MikroTik посредством API команд.
  • Сайт заглушка на 80 порту
  • Форма настройки и управления службой.

Службы в Windows называется BlackWall. Информацию и ошибки записываются в соответствующий системный журнал. База данных хранится в системной папке Windows.

Нужна помощь в написании отчета?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Поможем с характеристой и презентацией. Правки внесем бесплатно.

Заказать отчет

Заключение

В процессе прохождения преддипломной практики я приобрел огромный опыт в разработке программного обеспечении, проектировании баз данных, сайта и системном администрировании сети. Познакомился с оборудование MikroTik и их программным обеспечением RouterOS, WinBox. Во время преддипломной практики был разработан уникальный подход решение задачи. Данный результат был опубликован а различных интернет-ресурсах (http://habrahabr.ru/post/187574/ и http://chelaxe.ru/blacklist/), разработана библиотека для сторонних проектов (https://github.com/chelaxe/BlackList), найдены ошибки и недочеты в программном обеспечении MikroTik (http://habrahabr.ru/post/193118/; http://habrahabr.ru/qa/48864/; http://habrahabr.ru/post/187820/#bag) о чем было сообщено производителю. На данный момент данное решение используется различными операторами связи по всей России (Снежинск, Екатеринбург, Челябинск, Кодинск, Краснодар и др.)

[1]  Федеральный закон Российской Федерации «О внесении изменений в Федеральный закон «О защите детей от информации, причиняющей вред их здоровью и развитию» и отдельные законодательные акты Российской Федерации по вопросу ограничения доступа к противоправной информации в сети Интернет».

Список использованных источников

1. http://ru.wikipedia.org/wiki/Единый_реестр_запрещённых_сайтов – Единый реестр запрещённых сайтов;
2. http://eais.rkn.gov.ru/ – сайт единого реестра доменных имен, указателей страниц сайтов в сети «Интернет» и сетевых адресов, позволяющих идентифицировать сайты в сети «Интернет», содержащие информацию, распространение которой в Российской Федерации запрещено;
3. http://nap.rkn.gov.ru/ – сайт реестра доменных имен, указателей страниц сайтов в сети «Интернет» и сетевых адресов, позволяющих идентифицировать сайты в сети «Интернет», содержащие информацию, распространяемую с нарушением исключительных прав;
4. http://vigruzki.rkn.gov.ru/docs/description_for_operators_2013-07-16v2.0.pdf – Памятка оператору связи Версия 2.0 от 16.07.2013;
5. http://www.consultant.ru/document/cons_doc_LAW_149944/ – Распоряжение Роскомнадзора от 23.07.2013 N 18 «О рекомендациях по организации и техническим решениям по ограничению операторами связи доступа к сайтам в сети Интернет, содержащим информацию, распространение которой в Российской Федерации запрещено».

Средняя оценка 0 / 5. Количество оценок: 0

Поставьте оценку первым.

Сожалеем, что вы поставили низкую оценку!

Позвольте нам стать лучше!

Расскажите, как нам стать лучше?

439

Закажите такую же работу

Не отобразилась форма расчета стоимости? Переходи по ссылке