Данная тема актуальна на сегодняшний момент времени, так как у каждого человека на данный момент есть мобильный телефон, и даже не один. Также любой телефон может выйти из строя, для этого необходимы сервисы по ремонту сотовых телефонов.

Введение

Данная тема актуальна на сегодняшний момент времени, так как у каждого человека на данный момент есть мобильный телефон, и даже не один. Также любой телефон может выйти из строя, для этого необходимы сервисы по ремонту сотовых телефонов. И для крупных сервисов есть необходимость создания информационной базы для ведения отчета, подсчета деталей, а также учет прибыли и убытков. Данную работу легче всего реализовать в 1С:Предприятии, потому что данный продукт предоставляет все средства для её выполнения. Актуальность послужила основанием для выбора темы курсовой работы и предопределила ее задачи.

Конфигурация будет представлять готовый продукт, находящийся под общим владением и контролем, учитывающий детали разного ассортимента. Так же полностью автоматизированный продукт, с которым удобно работать, совершать различные операции по ремонту мобильных телефонов, поставщикам и изготовителям, сотрудникам.

Система имеет полный документооборот, позволяющий быстро и удобно формировать список первичных документов, необходимых для оформления создание и продажа деталей.

Программа предназначена для организаций, занимающихся ремонтом мобильных телефонов. Легкий в освоении, интуитивно понятный интерфейс программы, сэкономит время и не потребует много усилий. Используя данную программу, вам не придется покупать дополнительное программное обеспечение.

1.Теоретическая часть

1.1Общие данные

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Заказать курсовую

Модуль-это хранилище для текста программы на встроенном языке. В модуле располагается программный код. В отличие от платформы 7.7, где код мог располагаться и в свойствах элементов формы и в ячейках таблиц макета, в платформе 8.2 любая строчка кода должна располагаться в каком-либо модуле. Обычно модуль состоит из трех разделов — это раздел описания переменных, раздел описания процедур и функций, а так же раздел основной программы. Такая структура характерна практически для всех модулей платформы, за некоторым исключением. В некоторых модулях нет раздела описания переменных и раздела основной программы. Например, Модуль сеанса и любой Общий модуль.

Контекст выполнения модулей, в общем случае, делится на клиентский и серверный. Кроме того некоторые модули могут быть скомпилированы как на стороне клиента, так и на стороне сервера. А некоторые исключительно на стороне сервера или на стороне клиента.

1.2Виды модулей

1.2.1Модуль приложения

Модуль предназначен для того, чтобы отловить моменты запуска приложения (загрузки конфигурации) и завершения его работы. И в соответствующих событиях можно расположить процедуры проверки. Например, при начале работы приложения обновить какие-либо справочные данные конфигурации, при завершении работы поинтересоваться, а стоит ли вообще выходить из него, может день рабочий еще не закончился. Кроме того в нем перехватываются события от внешнего оборудования, например, торгового или фискального. Стоит отметить, что модуль приложения перехватывает описанные события только в случае интерактивного запуска. Т.е. когда создается само окно программы. Этого не происходит, если приложение запускается в режиме com-соединения.

В платформе 8.2 существует два различных модуля приложения. Это модуль Обычного приложения и модуль Управляемого приложения. Они срабатывают при запуске различных клиентов. Так модуль управляемого приложения срабатывает при запуске веб-клиента, тонкого клиента и толстого клиента в режиме управляемого приложения. А модуль обычного приложения срабатывает при запуске толстого клиента в режиме обычного приложения.

В модуле приложения можно располагать все разделы — описания переменных, процедур и функций, а так же описания основной программы. Модуль приложения компилируется на стороне клиента, поэтому это сильно ограничивает нас в доступности многих типов данных. Расширить контекст модуля приложения можно за счет методов общих модулей, для которых установлено свойство «Вызов сервера». Все переменные и методы, которые помечены как экспортные будут доступны в любом модуле конфигурации, работающем на стороне клиента. Но не следует размещать здесь большое количество методов. Чем больше в нем находится кода, тем больше время компиляции, а, следовательно, и время запуска приложения, что очень раздражает пользователей.

Модуль приложения обрабатывает события запуска и завершения приложения. Для обработки каждого из этих событий в модуле приложения существует пара обработчиков Перед… и При… Отличия между ними таково, что при выполнении кода в обработчике Перед… действие еще не свершилось и мы можем отказаться от его выполнения. Для этого предназначен параметр Отказ. В обработчиках при действие уже свершилось, и отказаться от запуска приложения или выхода из него мы не можем.

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Подробнее

1.2.2Модуль внешнего соединения

Назначение модуля аналогично назначению модуля приложения. В нем идет обработка точек старта и завершения приложения. Модуль внешнего соединения срабатывает, когда запуск приложения происходит в режиме com- соединения. Сам процесс внешнего соединения — это процесс не интерактивный. В этом режиме происходит программная работа с информационной базой и не происходит открытия окна приложения, что накладывает определенные ограничения на использование методов, предназначенных для интерактивной работы. В этом режиме нельзя использовать вызовы диалоговых форм, предупреждающих сообщений и т.п. Они просто не сработают.

Как и в модуле приложения, здесь доступны разделы описания переменных, методов и раздел основной программы. Так же можно объявлять экспортные переменные и методы. Отличие заключается в том, что в режиме com- соединения вся работа с информационной базой происходит на стороне сервера, поэтому модуль внешнего соединения компилируется исключительно на сервере. Соответственно в нем не доступны экспортные переменные и методы общих клиентских модулей.

1.2.3Модуль сеанса

Это узкоспециализированный модуль и предназначен исключительно для инициализации параметров сеанса. Это связано с тем, что процесс инициализации может потребовать исполнения какого-либо кода, а кроме того приложение может запускаться под разными клиентами (что приводит к выполнению различных модулей приложения или модуля внешнего соединения), а инициализацию параметров сеанса нужно производить в любом режиме запуска. Поэтому потребовался дополнительный модуль, который выполняется в любом режиме запуска приложения.

В модуле сеанса существует единственное событие «УстановкаПараметровСеанса», которое выполняется самым первым, даже раньше события модуля приложения ПередНачаломРаботыСистемы. В нем недоступны раздел объявления переменных и раздел основной программы. А так же нельзя объявлять экспортные методы. Модуль компилируется на стороне сервера.

1.2.4Общие модули

Модули предназначены для описания некоторых общих алгоритмов, которые будут вызываться из других модулей конфигурации. Общий модуль не содержит раздела описания переменных и раздела основной программы. В нем можно объявлять экспортные методы, контекст доступности которых будет определяться флагами компиляции. В связи с тем, что раздел описания переменных не доступен, определять глобальные переменные в общих модулях нельзя. Для этого нужно использовать функции общих модулей с кешированием возвращаемых значений или модуль приложения. Но стоит иметь в виду, что даже если свойство повторного использования общего модуля установлено в значение «На время сеанса», то и в этом случае время жизни закешированных значений не превышает 20 минут, с момента последнего к ним обращения.

Поведение общего модуля зависит от выставленных параметров (глобальный или нет, различные флаги компиляции, доступен ли вызов сервера и т.д.). При выставлении флагов следует отметить:

-Не желательно использовать больше одного флага компиляции. Методов, которые необходимо выполнять в разных контекстах не так много, и если все же такие методы потребуются, то для них можно выделить отдельный общий модуль.

-Если в методах модуля происходит массовая обработка данных, чтение и запись в базу данных, то для увеличения скорости работы лучше отключить контроль прав доступа, выставив флаг «Привилегированный». Этот режим доступен только для общих модулей, компилируемых на сервере.

-Флаг «Вызов сервера» имеет смысл, только если модуль компилируется «На сервере». Поэтому все остальные флаги компиляции стоит снять во избежание различных проблем.

-Хорошим правилом будет не использовать флаг «Глобальный» повсеместно. Это сократит время запуска приложения, а также улучшит читаемость кода.

1.2.5Модуль формы

Предназначен он для обработки действий пользователя, т.е. различных событий, связанных с вводом данных и обработкой корректности их ввода. Модуль обычной формы компилируется целиком на клиенте. Модуль же управляемой формы четко разграничен по контексту выполнения, поэтому все переменные и методы должны иметь директиву компиляции. Если директива в явном виде не указана, тогда эта переменная или метод будут скомпилированы на стороне сервера. В модуле формы доступны разделы описания переменных и методов, а также раздел основной программы.

1.2.6Модуль объекта

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Цена курсовой

Данный модуль характерен для многих объектов конфигурации и предназначен, в общем случае, для обработки событий объектов. Например, события записи и удаления объектов, событие проведения документов и т.д.

Некоторые события модуля объекта дублируют события модуля формы. Например, события связанные с записью. Однако следует понимать, что события модуля формы будут выполняться исключительно в конкретной форме объекта. В общем случае, этих форм может быть несколько. А события модуля объекта будут вызываться в любом случае, даже в момент программной работы с объектом. Поэтому, если необходимо выполнение некоторого кода во всех случаях, то лучше использовать для этого события модуля объекта.

Модуль объекта компилируется исключительно на сервере. В нем можно определять экспортные переменные и методы, которые будут доступны в других модулях конфигурации. При помощи этих свойств и методов мы можем значительно расширить функционал объекта.

1.2.7Модуль менеджера объекта

Этот модуль существует для многих объектов конфигурации. Основное предназначение данного модуля — это переопределение стандартного события выбора, которое возникает в момент ввода по строке и расширение функционала менеджера. Модуль компилируется на стороне сервера. В нем возможно определение экспортных свойств и методов. Вызов экспортных методов менеджера не требует создания самого объекта.

1.2.8Модуль команды

Команды — объекты, подчиненные прикладным объектам и конфигурации в целом. У каждой команды есть модуль команды, в котором можно описать предопределенную процедуру ОбработкаКоманды() для выполнения этой команды.

2.Практическая часть

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Цена курсовой

2.1Конфигурация

Конфигурация проектирования предприятия учета движения товара на оптовом складе содержит следующие объекты конфигурации, представленные на блок-схеме (Рисунок 1):

-4 справочника: Клиенты, Сотрудники, Номенклатура, Склад;

-2 документа: ПриходнаяНакладная и ОказаниеУслуги;

-1 регистр сведений Цены;

-2 регистра накопления: ОстаткиМатериалов и Продажи;

-3 отчета: Материалы, РеестрДокументовОказаниеУслуги, ВыручкаМастеров;

Рисунок 1 — блок-схема конфигурации

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Подробнее

2.2Справочники

Справочник — прикладной объект конфигурации, предназначенный для хранения списка данных. Характерной особенностью объекта конфигурации Справочник является то, что пользователь в процессе работы может самостоятельно добавлять новые элементы в справочник.

В конфигурации содержится 4 справочника:

-Клиенты;

-Сотрудники;

-Номенклатура;

-Склад;

2.2.1Справочник «Клиенты»

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Подробнее

В справочнике «Клиенты» ведется учет всех клиентов, использующих услуги сервиса, а так же их адрес и телефон. Справочник «Клиенты» содержит следующие реквизиты (Рисунок 2, Рисунок 3):

-Адрес (тип Строка (30));

-НомерТелефона (тип Число (16), неотрицательное);

-ИНН (тип Число (10), неотрицательное);

-ЮридическоеилиЧастноеЛицо (тип ПеречислениеСсылка.Лицо);

Рисунок 2- Список Справочника «Клиенты»

Рисунок 3 — Форма Справочника «Клиенты»

2.2.2Справочник «Сотрудники»

Справочник «Сотрудники» содержит необходимую информацию о сотрудниках сервиса (Рисунок 4, Рисунок 5):

-Справочник «Сотрудники» содержит следующие реквизиты:

-ЗанимаемаяДолжность (тип Строка);

-ДатаПринятияНаРаботу (тип Дата);

-Адрес (тип Строка);

-Телефон (тип Число);

Рисунок 5 — Форма Справочника «Сотрудники»

2.2.3Справочник «Номенклатура»

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Цена курсовой

Справочник «Номенклатура» содержит информацию об оказываемых услугах сервиса и наличии необходимых деталей (Рисунок 6, Рисунок 7).

Содержит следующие реквизиты:

-ВидНоменклатуры (тип ПеречисленияСсылка.ВидыНоменклатуры);

Рисунок 6 — Список справочника «Номенклатура»

Рисунок 7 — Форма справочника «Номенклатура»

2.2.4Справочник «Склад»

Содержит информацию о складах сервиса (Рисунок 8, Рисунок 9):

Рисунок 8 — Список справочника «Склад»

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Подробнее

Рисунок 9 — Форма справочника «Склад»

2.3Документы

Документ — прикладной объект конфигурации, предназначенный для описания информации о совершенных хозяйственных операциях или о событиях, произошедших в жизни организации вообще. Поведение документа отличается от поведения всех остальных объектов базы данных. Документ обладает способностью проведения. Факт проведения документа означает, что событие, которое он отражает, повлияло на состояние учета.

В данной конфигурации 2 документа:

-ПриходнаяНакладная (Рисунок 10, Рисунок 11);

-ОказаниеУслуги (Рисунок 12, Рисунок 13);

Рисунок 10 — Список Документа «ПриходнаяНакладная»

Рисунок 11 — Форма документа «ПриходнаяНакладная»

Рисунок 12 — Список документа «ОказаниеУслуги»

Рисунок 13 — Форма документа «ОказаниеУслуги»

2.3.1Документ «ПриходнаяНакладная»

В документе производится учет пришедших деталей, их количество цена и общая сумма. Реквизиты табличной части «Материалы»:

-Материал (тип СправочникСсылка.Номенклатура);

-Количество (тип Число (15));

-Цена (тип Число (15));

-Сумма (тип Число (15));

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Подробнее

2.3.2Модуль объекта «ПриходнаяНакладная»

Процедура «ОбработкаПроведения()» выполняет движения документа по регистру «ОстаткиМатериалов» (А.1).

2.3.3Модуль формы документа «ПриходнаяНакладная»

Процедура «МатериалыКоличествоПриИзменении(Элемент) рассчитывает сумму строки (А.2).

2.3.4Документ «ОказаниеУслуги»

В документе «ОказаниеУслуги» производится учет оказанных услуг, их количество и стоимость. На форме документа с помощью конструктора печати создана кнопка Печать, которая выводит на печать данные всего документа. Результат записать в поле «Всего».

Реквизиты:

-Склад (тип СправочникСсылка.Склад);

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Цена курсовой

-Клиент (тип СправочникСсылка.Клиенты);

-Мастер (тип СправочникСсылка.Сотрудники);

Реквизиты табличной части «ПереченьНоменклатуры»:

-Номенклатура (тип СправочникСсылка.Номенклатура);

-Количество (тип Число (15));

-Цена (тип Число(15));

-Сумма (тип Число (15));

-Стоимость (тип Число (15));

2.3.5Модуль формы документа «ОказаниеУслуги»

Процедура

«ПереченьНоменклатурыНоменклатураПриИзменении(Элемент)» производит расчет стоимости деталей.(А.3)

2.3.6Модуль объекта документа «ОказаниеУслуги»

Процедура «ОбработкаПроведения(Отказ, Режим)» выполняет движения по регистрам накопления «Продажи» и «ОстаткиМатериалов» (А4.).

2.4Отчеты

Объект конфигурации Отчет является прикладным объектом и предназначен для описания средств и алгоритмов, при помощи которых пользователь сможет получать необходимые ему выходные данные. Алгоритм формирования выходных данных описывается при помощи визуальных средств или с использованием встроенного языка.

Данная конфигурация содержит 3 отчета:

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Подробнее

-Материалы;

-РеестрДокументовОказаниеУслуги;

-ВыручкаМастеров;

2.4.1Отчет «Материалы»

Данный отчет подводит итог о количестве деталей на какой-то период времени, содержит информацию об их расходе и приходе (Рисунок 14).

Отчет «Материалы» содержит поля:

-Склад;

-Мастер;

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Подробнее

-Клиент;

-ПереченьНоменклатуры;

Рисунок 14 — форма отчета «Материалы»

2.4.2Отчет «РеестрДокументовОказаниеУслуги»

Отчет «РеестрДокументовОказаниеУслуги» отображает информацию об оказании услуг, лиц, кому оказывалась услуга а также мастер, работающий с клиентом (Рисунок 15).

Отчет содержит следующие поля:

-ПереченьНоменклатуры.Документ;

-Склад;

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Заказать курсовую

-Мастер;

-Клиент;

Рисунок 15 — Отчет «РеестрДокументовОказаниеУслуги»

2.4.3Отчет «ВыручкаМастеров»

-Мастер;

-Период;

-Клиент;

-Выручка;

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Цена курсовой

Рисунок 16 — отчет «ВыручкаМастеров» в виде таблицы

Рисунок 17 — отчет «ВыручкаМастеров» в виде диаграммы»

2.5Регистры сведений

Регистр Сведений — объект конфигурации, предназначенный для описания структуры хранения данных в разрезе нескольких измерений.

В конфигурации содержится 1 регистр сведений:

-Цены (Рисунок 18);

Рисунок 18 — Регистр сведений «Цены»

2.5.1Регистр сведений «Цены»

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Подробнее

Регистр сведений «Цены» содержит измерение «Номенклатура» (тип СправочникСсылка.Номенклатура) и ресурс «Цена» (тип Число (15)). На его основании заполняется последним актуальным значением поле цена документа «ОказаниеУслуги».

2.6Регистры накопления

Объект конфигурации Регистр накопления является прикладным объектом и предназначен для описания структуры накопления данных. Отличительной особенностью регистра накопления является то, что он не предназначен для интерактивного редактирования пользователем.

В конфигурации содержится 2 регистра накопления:

-ОстаткиМатериалов (Рисунок 19);

-Продажи (Рисунок 20);

2.6.1Регистр накопления «ОстаткиМатериалов»

Регистр накопления «ОстаткиМатериалов» содержит 2 измерения: Материал (тип СправочникСсылка.Номенклатура) и Склад (тип СправочникСсылка.Склад), и 1 ресурс Количество (тип Число (15)). Формирует движения на основании документов «ПриходнаяНакладная» (тип движения — приход) и документа «ОказаниеУслуги» (тип движения — расход).

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Подробнее

Рисунок 19 — Движение регистра накопления «ОстаткиМатериалов» по документам «ОказаниеУслуг» и «ПриходнаяНакладная»

2.6.2Регистр накопления «Продажи»

Регистр накопления содержит 3 измерения:

-Номенклатура (тип СправочникСсылка.Номенклатура);

-Клиент (тип СправочникСсылка.Клиенты);

-Мастер (тип СправочникСсылка.Сотрудники);

и 1 ресурс «Количество» (тип Число (15)). Формирует движение на основе документа «ОказаниеУслуг».

Рисунок 20 — Движение регистра накопления «Продажи» по документу «ОказаниеУслуги»

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Заказать курсовую

2.7Общие модули

В данной конфигурации используется 2 общих модуля:

-РаботаСДокументами;

-РаботаСоСправочниками.

2.7.1Общий модуль «РаботаСДокументами»

В данном модуле рассчитывается стоимость деталей для текущей строки табличной части, равной произведению цены и количества (А5.).

2.7.2Общий модуль «РаботаСоСправочниками»

В данном модуле получаем последнюю цену для товара из регистра сведений «Цены» (А6.)

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Заказать курсовую

2.8Константы

Константы — это прикладные объекты конфигурации <#»justify»>-НазваниеОрганизации (тип Строка (20));

-НомерТелефона (тип Число (11));

-Email (тип Строка (неограниченная длина));

-Сайт (тип Строка (20));

Рисунок 21 — форма «ФормаКонстант»

Заключение

программа конфигурация ремонт сервис

В данной курсовой работе рассмотрена конфигурация сервиса по ремонту сотовых телефонов. Конфигурация представляет собой готовый продукт, с которой может работать любой пользователь или же сотрудник организации. Это полностью автоматизированный программный продукт.

Конфигурация удобна в использовании. Её легко понять простому пользователю, не работающему в данной программе долго.

Достоинства конфигурации:

-Удобный интерфейс для использования;

-В модуле получаем последнюю цену для товара из регистра сведений «Цены».

Деятельность организации «» подходит для демонстрации возможностей 1С: Предприятия 8.2. Она позволяет довольно широко показать возможность формирования различных отчетов и итоговых данных на основе имеющейся информации, выводить на печать бумажные аналоги электронных документов.

Список использованных источников

1.Радченко М.Г. 1С: Предприятие 8.2 « Практическое пособие разработчика»/ М.Г. Радченко. — М.: ООО «1С Паблишинг», 2004.

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Цена курсовой

2.Радченко М.Г. ИТС по книге 1С: Предприятие 8.0 « Практическое пособие разработчика»/ М.Г. Радченко. — М.: ООО «1С Паблишинг», 2004.

3.Митичкин С. «Практика программирования в среде 1С:Предприятие»/

С. Митичкин — М.: «КомБук», 2004.

.Рязанцева Н. 1С: Предприятие «Комплексная конфигурация. Секреты работы»/ Н.Рязанцева, Д.Рязанцев — Санкт-Петербург «БХВ-Петербург» 2005.

5.Постовалов С. 1С: Предприятие 8 «Зарплата и Управление Персоналом»/ С. Постовалов, А. Постовалова. Санкт-Петербург «БХВ-Петербург» 2008.

6.Шустикова Т.Б. 1С:Предприятие 8.0. Управление торговлей / Т.Б. Шустикова — М.: «НТ Пресс», 2006. — 284с.

7.Габец А.П. Профессиональная разработка в системе 1С: Предприятие 8.0 / А.П. Габец. — М.: ООО «1С: Паблишинг», 2006.

Приложение

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Цена курсовой

А.1. Процедура — Программный код модуля объекта документа «ПриходнаяНакладная»

Процедура ОбработкаПроведения(Отказ, Режим)

// регистр ОстаткиМатериалов Приход

Движения.ОстаткиМатериалов.Записывать = Истина;

Для Каждого ТекСтрокаМатериалы Из Материалы Цикл

Движение = Движения.ОстаткиМатериалов.Добавить();

Движение.ВидДвижения = ВидДвиженияНакопления.Приход;

Движение.Период = Дата;

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Подробнее

Движение.Материал = ТекСтрокаМатериалы.Материал;

Движение.Склад = Склад;

КонецЦикла;

КонецПроцедуры

А.2 Процедура — Программный код модуля формы документа «ПриходнаяНакладная»

&НаКлиенте

Процедура МатериалыКоличествоПриИзменении(Элемент)

СтрокаТабличнойЧасти=Элементы.Материалы.ТекущиеДанные;

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Заказать курсовую

РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);

КонецПроцедуры

&НаКлиенте

Процедура МатериалыЦенаПриИзменении(Элемент)

СтрокаТабличнойЧасти=Элементы.Материалы.ТекущиеДанные;

РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);

КонецПроцедуры

&НаКлиенте

Процедура МатериалыНоменклатураПриИзменении(Элемент)

//Получить текущую строку табличной части.

СтрокаТабличнойЧасти=Элементы.Материалы.ТекущиеДанные;

//Установить цену.СтрокаТабличнойЧасти.Цена=РаботаСоСправочниками.РозничнаяЦена(Объект.Дата , СтрокаТабличнойЧасти.Номенклатура);

//Пересчитать сумму строки. РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);

КонецПроцедуры

А.3. Процедура — Программный код модуля формы документа «ОказаниеУслуги»

&НаКлиенте

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Заказать курсовую

Процедура ПереченьНоменклатурыКоличествоПриИзменении(Элемент)

СтрокаТабличнойЧасти=Элементы.ПереченьНоменклатуры.ТекущиеДанные;

РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);

КонецПроцедуры

&НаКлиенте

Процедура ПереченьНоменклатурыЦенаПриИзменении(Элемент)

СтрокаТабличнойЧасти=Элементы.ПереченьНоменклатуры.ТекущиеДанные;

РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Подробнее

КонецПроцедуры

&НаКлиенте

Процедура ПереченьНоменклатурыНоменклатураПриИзменении(Элемент) СтрокаТабличнойЧасти=Элементы.ПереченьНоменклатуры.ТекущиеДанные; СтрокаТабличнойЧасти.Цена=РаботаСоСправочниками.РозничнаяЦена(Объект.Дата , СтрокаТабличнойЧасти.Номенклатура);

РаботаСДокументами.РассчитатьСумму(СтрокаТабличнойЧасти);

КонецПроцедуры

А.4. Процедура — Программный код модуля объекта документа «ОказаниеУслуги»

Процедура ОбработкаПроведения(Отказ, Режим)

Движения.Продажи.Записывать = Истина;

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Заказать курсовую

Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл

Движение = Движения.Продажи.Добавить();

Движение.Период = Дата;

Движение.Номенклатура =ТекСтрокаПереченьНоменклатуры.Номенклатура;

Движение.Клиент = Клиент;

Движение.Мастер = Мастер;

Движение.Количество = ТекСтрокаПереченьНоменклатуры.Количество;

Движение.Стоимость=ТекСтрокаПереченьНоменклатуры.Стоимость;

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Заказать курсовую

КонецЦикла;

Движения.ОстаткиМатериалов.Записывать = Истина;

Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл

Если ТекСтрокаПереченьНоменклатуры.Номенклатура

.ВидНоменклатуры=Перечисления.ВидыНоменклатуры.Материал Тогда

Движение = Движения.ОстаткиМатериалов.Добавить();

Движение.ВидДвижения = ВидДвиженияНакопления.Расход;

Движение.Период = Дата;

Движение.Материал = ТекСтрокаПереченьНоменклатуры.Номенклатура;

Движение.Склад = Склад;

Движение.Количество = ТекСтрокаПереченьНоменклатуры.Количество;

КонецЕсли;

КонецЦикла;

КонецПроцедуры

А.5. Процедура — Программный код общего модуля «РаботаСДокументами»

Процедура РассчитатьСумму(СтрокаТабличнойЧасти)Экспорт

СтрокаТабличнойЧасти.Сумма=СтрокаТабличнойЧасти.Количество*СтрокаТабличнойЧасти.Цена;

КонецПроцедуры

А.6. Процедура — Программный код общего модуля «РаботаСоСправочниками»

Функция РозничнаяЦена(АктуальнаяДата, ЭлементНоменклатуры) Экспорт

//Создать вспомогательный объект Отбор.

Отбор=Новый Структура(«Номенклатура», ЭлементНоменклатуры);

//Получить актуальные значени ресурсов регистра.

ЗначенияРесурсов=РегистрыСведений.Цены.ПолучитьПоследнее(АктуальнаяДата, Отбор);

Нужна помощь в написании курсовой?

Мы - биржа профессиональных авторов (преподавателей и доцентов вузов). Наша система гарантирует сдачу работы к сроку без плагиата. Правки вносим бесплатно.

Заказать курсовую

КонецФункции

Средняя оценка 0 / 5. Количество оценок: 0

Поставьте оценку первым.

Сожалеем, что вы поставили низкую оценку!

Позвольте нам стать лучше!

Расскажите, как нам стать лучше?

132

Закажите такую же работу

Не отобразилась форма расчета стоимости? Переходи по ссылке